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In this post we’re going to learn how to create some super cool key performance indicator (KPI)
data cards in Excel.

These are great for drawing attention to a single metric like the total sales in your dashboards.
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In this post we’re going to get extra fancy and add some little additions to the cards like a
percentage change over the previous year and a small line chart in the background.

To build these fancy KPI cards, we are going to pull out pivot tables, pivot charts, GetPivotData,
shapes and custom number formatting from our toolbox of Excel tricks.
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Data Setup

OrderDate ﬂ ProductName u OrderQuantity u OrderTotal ﬂ
2017-01-01 Road Tire Tube 2 57.98
2017-01-01 Sport-100 Helmet, Red 1 534.99
2017-01-01 HL Road Tire 1 532,60
2017-01-01 Road Tire Tube 2 53.99
2017-01-01 Road-250 Black, 52 1 $2,181.56
2017-01-01 HL Road Tire 1 532.60
2017-01-01 Sport-100 Helmet, Black 1 533.64
2017-01-01 Long-Sleeve Logo lersey, M 1 548.07
2017-01-01 Mountain Tire Tube 2 54.99
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In this example I’'m going to be using the AdventureWorks data set which has order data for a
fictitious bike shop.

This data contains the Order Date and Order Total which we will be using for the data cards.

Pivot Table Setup



We will then need to create two pivot tables with this order data.

This can be done by selecting a cell inside the order data and going to the Insert tab of the
ribbon and selecting the PivotTable command.

Row Labels i Sum of OrderTotal Sum of OrderTotal2

= 2015 56,404,934
Jan 5585,313
Feb 5532,226
Mar $643,436
Apr 5653,364
May $659,326
Jun 5669,989
Jul $486,115
Aug 5536,453
Sep $344,063
QOct 5404,277
Nov $326,611
Dec 5563,762
-12016 40,187,824 43.4%
lan 5432,426 -26.1%
Feb $474,163 -10.9%
MWar 5471,962 -26.6%
Apr $494,957 -24.2%
May $545,535 -17.3%
Jun $533,825 -20.3%
Jul 5809,384 B6.5%
Aug $779,311 45.3%
Sep $928,315 169.8%
Oct $1,004,222 148.4%
Mow 51,109,128 239.6%
Dec $1,604,596 184.6%
Grand Total 515,592,758

For the first pivot table, we need to add the Order Date field into the Rows area and two
instances of the Order Total field into the Values area.

This should group the order date into years, quarters and months automatically. We will only
need the year and month grouping, so we can remove the quarter grouping from the pivot table.
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If Excel does not group our order dates automatically, the dates will be listed down the rows of
the pivot table and we can right click on them and choose the Group command from the menu.

The first instance of the Order Total in the Values area of our pivot table will be a regular
SUM. For the second instance we will create a percent difference calculation.

Row Labels B4 Sum of OrderTotal Sum of OrderTotal2
-12015 $6,404,934 6404933.58
Jan 585,313 585312.6486
Feb 5532,226 53222'[‘|ﬂ'_§|-rr(':upy ¥ Mo Calculation
May $659,326 ? 65932 Number Format... % of Column Total
Jun $669,989 == 66998 % Refresh % of Row Total
Jul $486,115 48611 % Of...
Aug $536,453 33645 sort ' % of Parent Row Total
Sep 5344,063 34406 > FRemowve "Sum of OrderTotal2" % of ;grent Colurnn Total
oct vA04,277 w0427 Summarize Values By ' % of Parent Total
MNov 5326,611 32081 Show Values As , _ =
Dec $563,762 56376 = Ditference From..
-12016 49,187,824 91878 = “howbeials % Difference From..
lan 5432,426 43242 [ig Value Field Settings... Running Total In...
Feb 474,163 47416 PivotTable Options... % Running Total In..

N Hide Field List Rank Smallest to Largest...

Rank Largest to Smallest..,

Index

Mare Opticns...



We can right click on the numbers in our second Order Total field and then choose Show
Values As = % Difference From.

Show Values As (Sum of OrderTotal2) ? >

Calculation: % Difference From

EBase Field: |Years e
Base jtem: [FIETETS N I -

Then we can choose Years as our base field and Previous as our base item. This will calculate
the percent difference from the current year to the previous year for each month.

Sum of OrderTotal Column Labels

Row Labels  [§d 2015 2016 Grand Total
Jan $585,313  $432,426 $1,017,738
Feb 532,226 $474,163 51,006,389
Mar $643,436 $471,962 $1,115,398
Apr 653,364 $494,957 91,148,321
May $659,326 $545,535 $1,204,861
Jun $669,989 5533,825 91,203,814
Jul $486,115 5809,384 $1,295,499
Aug 536,453 §779,311 $1,315,764
Sep $344,063 $928,315 91,272,378
Oct $404,277 $1,004,222 $1,408,499
Nov $326,611 51,109,128 91,435,740
Dec $563,762 $1,604,596 $2,168,358
Grand Total $6,404,934 $9,187,824 $15,502,758

For our second pivot table, we will add the Order Date Month grouping to the Rows area, the
Order Date Year grouping to the Columns area and the Order Total field to the Values area.

Both pivot tables can then be filtered on the years to show only the two years of data which we
want to compare.
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We will also need subtotals in the first pivot table. We can add these by selecting the pivot table
and going to the Analyze tab = Subtotals = Show all Subtotals at the Top of Group.

Extract The KPI With GetPivotData

Now we can use the GetPivotData formula to extract the numbers from our pivot tables which
will feature as the key performance indicator. In our case this will be the total orders for 2016
and the percent difference from 2016 to 2015.
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v Generate GetPivotData

First, we need to turn on the GetPivotData feature. This is the (sometimes annoying) feature that
automatically creates a GetPivotData formula when trying to reference a cell inside a pivot table.

This should be enabled by default, but in case it is not, go to the Analyze tab and click on the
small arrow next to the Options then select Generate GetPivotData (it should have a small
check mark next to it when it’s on).



A B C D E F G H

1

2 I |=GErP|Vr:JTDATA{"s_um of OrderTotal", 5852, "Years",2016)|

3 =201 $6,404,934

4| Jan $585,313

5 | Feb £532,226

6 Mar $643,436

7 | Apr $653,364

g May $659,326

9 Jun $669,989

10| Jul $486,115

11 Aug $536,453

12| Sep $344,063

13| oct $404,277

14| Nov 5326,611

15| Dec 45A2 TRD Sum of OrderTotal Column Labelsﬂ

16 -2016 I 69,187,824 43.4% Rowlabels 2015 2016 Grand Total
17 Jan S432,476 -26.1% Jan $585,313 $432,426 $1,017,738
12| Feb 474,163 -10.9% Feb $532,226 $474,163 51,006,289
19| Mar $471,962 -26.6% Mar $643,436 $471,952 51,115,398
20| Apr $494,957 -24.2% Apr $653,364 $494,957 51,148,321
21 May $545,535 -17.3% May $659,3226 $545,535 $1,204,861
22| Jun $533,825 -20.3% Jun $669,989 $533,825 $1,203,814
23 | Jul 5809,384 66.5% Jul $436,115 $209,384 51,295,499
24 | Aug 5779,311 45.3% Aug 536,453  $779,311 $1,315,764
25| Sep $928,315 169.8% Sep $344,063 $928,315 51,272,378
26 oct $1,004,222 148.4% oct $404,277 $1,004,222 51,408,499
27| Nov $1,109,128 239.6% Nov $326,611 $1,109,128 51,435,740
28 | Dec 51,604,596 184.6% Dec $563,762 $1,604,596 52,168,358
23|  Grand Total $15,592,758 Grand Total $6,404,934 $9,187,824 $15,502,758
30

In a cell outside of the pivot table, we can create a formula that references the 2016 subtotal in
the pivot table. This will automatically create a GetPivotData formula to reference the value
inside the pivot table.
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C

D

E

I I I I
1 —1 | ————1 |
3|l Row Labels EY sum of OrderTotal_sum of OrderTotal? |
3| =2015 $6,404,934
4 Jan §585,313
5 | Feb §532,226
5_ Mar 5643,436
7_ Apr 5653,364
8_ May 5659,326
9_ Jun $669,989
10_ Jul $486,115
1 1_ Aug 5536,453
1 2_ Sep 5344,063
1 3_ Oct $404,277
14_ MNov 5326,611
1 5_ Dec 3563,76%
16 2016 so187,8240 ________43.4%)
17| Jan $432,426 26.1%
18_ Feb 5474,163 -10.9%
19 Mar $471,962 -26.6%
20| Apr $494,957 -24.2%
21 May $545,535 -17.3%
22 | Jun 4533,825 -20.3%
23 Jul $809,384 66.5%
24 | Aug $779,311 45.3%
25| sep $928,315 169.8%
26 | Oct $1,004,222 148.4%
27| Nov 1,109,128 239.6%
28 Dec $1,604,596 124.6%
29_ Grand Total $15,502,758
30

| =GETPIVOTDATA("Sum of OrderTotal2",5652,"Years", 2016}|

Sum of OrderTotal Column Labels E

Row Labels B 2015 2016 Grand Total
Jan 4585,313  $432,426 $1,017,738
Feb §532,226 $474,163 51,006,389
Mar 4643,436 $471,962 51,115,393
Apr 4653,364 9494,957 $1,148,321
May 4659,326 $545,535 $1,204,861
Jun 4669,989 $533,825 $1,203,814
Jul $486,115 $809,384 51,295,499
Aug 4536,453 $779,311 $1,315,764
Sep $344,063 $928,315 $1,272,378
Oct $404,277 51,004,222 51,408,499
Mov $326,611 51,109,128 51,435,740
Dec 4563,762 51,604,596 $2,168,358
Grand Total $6,404,934 9,187,824 $15,502,758

In another cell outside of the pivot table, we can create another GetPivotData reference to the
2016 percent difference subtotal.

A B . C D B F . G
1
2 $9,187,324
3| -2015 6,404,934 A43.4%
4 lan 5585,313
5 | Feb $532,226
6 Mar $643,436
7 | Apr -
I AW P T WL A

Add formatting to the

GetPivotData references.

We will need to format these two values as the formatting in the cells is how they will be
formatted in our data cards.




The order subtotal can be formatted as a currency with no decimal places. Go to the Home tab
and select Currency from the Number section of the ribbon and adjust the decimal places to
show none.

Format Cells ? >
Number Alignment Font Border Fill Protection
Categorny:
General Sample
Mumber A 43.4%
currency
Accounting Tvpe:
Date
Percentage _SEEesl_ SR EEED S D ~
Fraction REEEQ o FEEE] o KT o @ -
Scientific 5 & E20,00 o-5% £ 52000 - 5501 o @ -
Text A EEEQDD - EESQDD o T o @ -
Soocial E-.*.‘r-.?-.?'l}.'l}l} h T T
[custom | [N
0.0%
A 0.0 %Y -0.0 %
[S-en-CAlmmmm d, vy
[S-en-US]h:mm:ss AR/PM
G #0.0 W
Delete

Type the number format code, using one of the existing codes as a starting point.

The percent difference subtotal we will add a custom format with up and down arrow symbols
for positive and negative values. Press Ctrl + 1 to open the Format Cells dialog box.

1. Go to the Number tab.

2. Select Custom from the list.

3. Adda 0.0 s;v -0.0 % into the Type field and press the OK button. This will display
an up arrow for any positive numbers and a down arrow for any negative numbers.



Creating The Data Card
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We will need to add in 4 rectangle shapes to our Excel worksheet. One is for the background,
two will be to display the subtotals and one will be to display a title heading.

Go to the Insert tab and click on the Shapes button to select from all the various shapes. Select
the Rectangle shape and then click and drag in the sheet to draw the shape.
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With the 4 shapes we will format the fill and outline based on its purpose.

1. For the background the Shape Fill and Shape Outline can be a solid colour. We will
later be using both black and white for font colour so we should pick a colour for the fill
that will contrast nicely with black and white. A black outline and green fill will work
nicely.

2. For the subtotal we will choose No Fill and No Outline. This way the background will
show through.

3. For the percent different subtotal we will also pick No Fill and No Outline.

4. For the title we will pick a white Shape Fill and a black Shape Outline.

If we create the shapes in this order then we won’t need to adjust the layering order later on. The
background shape will be underneath the other shapes.

Subtotal And Percent Difference Subtotal Data Cards
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Now we can add the subtotal to our rectangle with no fill or outline.

1. Select the shape.

2. In the formula bar type an = then select the cell that contains the GetPivotData reference
to our subtotal value.

3. Go to the Home tab and increase the font size and change the font colour.

4. We can also Middle and Center align the text.

We need to do the same with our second rectangle with no fill or outline and our percent
difference subtotal value.

Create A Data Card Title Heading

Our last rectangle shape will contain our data card title heading. We can simply select the shape
and start typing our title. Then we can go to the Home tab to increase the font size, change the
font colour, middle and center align the text.

Arrange Align And Group The Shapes
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Now that we’ve got all the shapes, we can select and drag them around to arrange them like the
above picture.

When we’re satisfied with the approximate location, we can align them perfectly with the
alignment tools. Select all the shapes (select one then press Ctrl + A), then go to Drawing Tools
Design tab = Arrange section = Align = Align Center.

We can also group them together so we don’t accidentally mess up the alignment. With all the
shapes selected go to the Drawing Tools Design tab = Arrange section = Group = Group.

Adding A Line Chart
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This is where we’re going to use our second pivot table. Select it and go to the Analyze tab and
press the PivotChart command.
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We also want to remove all the buttons, axis, grid lines, move the legend to the bottom, and
remove the fill and outline.



1. Right click on any of the buttons and select Hide All Field Buttons on Chart.

2. Select both axis and press Delete.

3. Select the grid lines and press Delete.

4. Move the legend to the bottom. Select the chart and go to the PivotChart Tools Design
tab = Add chart Element = Legend = Bottom.

5. Remove any fill. PivotChart Tools Format tab = Shape Fill = No Fill.

6. Remove any outline. PivotChart Tools Format tab = Shape Outline = No Outline.

7. We can also change the legend text to white for better visibility against our green
background. Select the legend and go to the Home tab to change the font colour.
8. Change the chart colour palette to one that contrasts well with the

background. PivotChart Tools Design tab = Change Colors = Pick from one of the
colour palettes.

Arrange Line Chart Over The Data Card

Now, we can place the chart over the data card.

Select the chart and go to the PivotChart Tools Format tab = Align = Snap to Shape. This
will make it easy to line up the edges of the chart to the edges of the data card background.

Now drag the chart edges so they are lined up with the background. The chart will be the top
layered object since it was created last. We want this to be just underneath the large total order

number. With only the chart selected go to the PivotChart Tools Format tab = Send
Backwards = Send Backwards until it is behind the order total number.

Now we can group everything together. Select every object and go to Drawing Tools
Format tab = Group = Group.
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We now have a fancy data card which can be moved around and resized as one object.

Add Slicers To Control The Data Card

Since the data card is all based on pivot tables, we can now add slicers to control the data card!
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Select either pivot table and go to the Analyze tab and select the Insert Slicer command.



Insert Slicers
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We can select any field(s) in our data for a slicer. In this example we’ll add a slicer for our

products.
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We also need to connect the new slicer(s) to the other pivot table. Right click on the slicer and
select Report Connections from the menu, then check off both pivot tables in the Report
Connections dialog box.

Now the data card will show the 2016 total orders for any set of products selected in the slicer as
well as the percent change from 2015.




Conclusions

With a little work and creativity, we can make some pretty cool stuff for our Excel dashboards.

Setting up the pivot tables correctly to extract the metrics we want to display in the data cards is
essential to the whole process. The pivot tables take care of summarizing the key metrics of our
data.

The shapes can’t directly reference the values in our pivot tables though, so it’s necessary to use
the GetPivotData formula as an intermediate step to reference the values.

I’d love to hear about what kind of cool dashboard visuals you’ve been able to make. Let me
know in the comments!
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